注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

God is U 做自己的上帝

富原孤島--只发优质级的文章

 
 
 

日志

 
 

解决Linux下安装MySQL版本冲突  

2009-04-06 04:53:32|  分类: [LINUX] |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

///:操作平台RHEL 4 AS,在安装MYSQL5的时候提示与MYSQL4版本冲突

1、 先把系统里安装的所有mysql找出来

#rpm -qa|grap -i mysql 运行此命令后,显示所有列表

mysql-4.1.20-1.RHEL4.1

mysqlclient10-3.23.58-4.RHEL4.1

2、 将列表一一强制删除:

#rpm -ev --nodeps mysql-4.1.20-1.RHEL4.1

#rpm -ev --nodeps mysqlclient10-3.23.58-4.RHEL4.1

3、 将老版本的几个文件手工删除:

#rpm -f /etc/my.cnf

#rpm -rf /usr/var/lib/mysql

进行mysql的全新安装,需要的软件包:

MySQL-server-community-5.0.51a-0.rhel4.i386.rpm   

MySQL-client-community-5.0.51a-0.rhel4.i386.rpm   

 

将RPM软件包传到RHEL服务器上,进入文件所在目录

#rpm -ivh MySQL-server-community-5.0.51a-0.rhel4.i386.rpm   

#rpm -ivh MySQL-client-community-5.0.51a-0.rhel4.i386.rpm   

运行mysql命令可以进入,运行#service mysql stop (默认情况下安装后会启动mysql)

当然,可能有些配置要重新设置一下,就跟当初第一次安装MYSQL一样就OK了

  评论这张
 
阅读(263)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017